[Logo] Argo Navis Users' Group
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Top Downloads] Top Downloads   [Groups] Back to home page 
[Register] Register /  [Login] Login 
Used Argo Navis - batteries leaked a bit, how to clean battery compartment RSS feed
Forum Index » User Forum
Author Message
ebertzm-an

[Avatar]

Joined: 13/02/2020
Messages: 2
One of the batteries leaked. The terminals are a little corroded, but the unit did fire up before I checked and removed the batteries.

Online advice is to use vinegar to clean terminals. I want to get user's opinions on this technique. I would use a facial tissue or q-tip (cotton on a s=mall stick) to not get the liquid in the case. This could be difficult, though.

Also there are small white dots of something (mold?) in the RJ-45 and RJ-11 jacks. Any ideas on that?

Thanks in advance.
wildcard

[Avatar]

Joined: 17/10/2019
Messages: 97
Location: Mount Kuring-Gai NSW Australia
Offline
Hi,

As the vented alkaline battery material is quite corrosive, it is important to clean it up as quickly as possible.

A little vinegar or lemon juice on a cotton bud can help neutralise the material.

We recommend to then additionally clean it with a cotton bud soaked with a good electrical spray such as CRC-226.

We also recommend you unfasten the screws holding the back shell of the enclosure on and check if any material has reached the circuit board.
Clean it in a similar way.

The white specks on the connectors are also indicative of a battery having leaked or vented. Again, use the same technique to clean them.

As all battery manufacturers recommend, remove alkaline batteries from equipment when it won't be used for an extended period of time.


Gary Kopff
Managing Director
Wildcard Innovations Pty. Ltd.
20 Kilmory Place, Mount Kuring-Gai
NSW. 2080. Australia
Phone +61-2-9457-9049
wildcard@wildcard-innovations.com.au
https://www.wildcard-innovations.com.au
[Email] [WWW]
ebertzm-an

[Avatar]

Joined: 13/02/2020
Messages: 2
Thank you Gary!
 
Forum Index » User Forum
Go to:   
Mobile view
Powered by JForum 2.6.2 © 2019 JForum Team • Maintained by Andowson Chang and Ulf Dittmer